Aktuelle Stable: 1.6.0.3 - Aktuelle Beta: 1.7.0.0 / 04.05.2017
Willkommen auf DZCP.deUser online: 0
Verwende bitte "https://www.dzcp.de" um dich über eine verschlüsselte Verbindung anzumelden!
Forum
deV!L`z Clanportal Forum: Supportforum Thread: Installation auf Lokalem Server
Installation auf Lokalem Server Seite: « 1 2 »
#1 am 16.07.2017 um 07:21 Uhr Diesen Beitrag zitieren
WebPolar
User
Posts: 1

Guten Tag zusammen,

ich habe heute versucht DZCP 1.6 auf meinem XAMPP Server zu installieren. Leider hat er mich nach dem eingeben der Benutzerdaten folgenden Fehler geliefert.


Fatal error: Uncaught Error: Call to a member function query() on null in C:/xampp-7/htdocs/ed/inc/config.php:250 Stack trace: #0 C:/xampp-7/htdocs/ed/_installer/conf/mysql.php(15): db('DROP TABLE IF E...') #1 C:/xampp-7/htdocs/ed/_installer/install.php(456): install_mysql('#', '#', '#', '#.') #2 {main} thrown in C:/xampp-7/htdocs/ed/inc/config.php on line 250

?

?

PS: Wo die Rautezeichen drin sind standen eigendlich Benutzername, Passwort und E-Mail welche ich aber aufgrund des Datenschutzes entfernt habe.

Danke schonmal f?r eure Hilfe

?

MfG: Benjamin



zuletzt editiert von WebPolar am 16.07.2017 06:27 Uhr 
IP gespeichert
#2 am 16.07.2017 um 12:21 Uhr Diesen Beitrag zitieren
Hammermaps.de DEV
Coder
Posts: 369

Welche Version der 1.6 hast du runtergeladen und welche version von XAMPP verwendest du?

 
IP gespeichert
#3 am 17.03.2018 um 16:11 Uhr Diesen Beitrag zitieren
brainmark
User
Posts: 18

Hi.

Ich greife dieses Thema noch einmal auf, da ich auch dieses Problem habe und so langsam an mir selber zweifel.
Heute habe ich mir das aktuelle Xampp (7.2.3 / PHP 7.2.3) runtergeladen und installiert.
Fix die aktuellste DZCP-Version von dzcp.de runtergeladen und nach c:xampphtdocsDZCP kopiert.

Allerdings bekomme ich bei der Installation (http://127.0.0.1/DZCP/_installer/install.php?action=database&do=install) folgende Meldung:

 

Fatal error: Uncaught Error: Call to a member function query() on null in C:xampphtdocsDZCPincconfig.php:256 Stack trace: #0 C:xampphtdocsDZCP_installerconfmysql.php(15): db('DROP TABLE IF E...') #1 C:xampphtdocsDZCP_installerinstall.php(456): install_mysql('test', 'tester', '1234', 'test@test.d...') #2 {main} thrown in C:xampphtdocsDZCPincconfig.php on line 256

So langsam befürchte ich, das es an der aktuellen Xampp-Version bzw. php-Version liegt.



zuletzt editiert von brainmark am 17.03.2018 16:12 Uhr 
IP gespeichert
#4 am 18.03.2018 um 15:52 Uhr Diesen Beitrag zitieren
brainmark
User
Posts: 18

Okay, Nachtrag.

Ich habe die DZCP-Version 1.6-1604f1 jetzt mit folgenden Xampp-Verisonen ohne Erfolg getestet:

  • 7.2.3.0
  • 7.1.15.0
  • 7.0.28.0

Nach jeder Deinstallationhabe ich den PC neu gestartet und dann nie nächste Version installiert.

Also alles frische Neuinstallationen mit einer neu angelegten Datenbank "dzcp" (utf8_general_ci).

Was mir gerade aufgefallen ist: Webspell NOR läuft auch nicht richtig.

Werde das mal weiter verfolgen...

 
IP gespeichert
#5 am 18.03.2018 um 16:34 Uhr Diesen Beitrag zitieren
xero.ru
Designer
Posts: 32

#####################
Support Informationen
#####################

#####################
DZCP Allgemein
#####################
DZCP Version: 1.6.0.4
DZCP Release: 20.12.2017
DZCP Build: 1604.02.21
DZCP Template: wegowner
Domain: http://localhost/dzcp_1.6

#####################
Server Versionen
#####################
Server OS: ------------------------------
Webserver: Apache/2.4.29 (Win32) OpenSSL/1.1.0g PHP/7.2.1
PHP-Version: 7.2.1 (apa)
MySQL-Server Version: 5.5.5-10.1.30-MariaDB
MySQLi-Persistente Datenbankverbindung: Off

 

läuft ohne problemme

habe 4 verschiedene Versionen laufen und 10 Templates

probiere mal das :

https://netbeans.org/downloads/index.html

ist ein Programm mit Xampp integriert, mit dem läuft es auf jeden fall

 

viel erfolg



zuletzt editiert von xero.ru am 18.03.2018 16:41 Uhr 



dzcp.gif

IP gespeichert
#6 am 19.03.2018 um 11:08 Uhr Diesen Beitrag zitieren
-{ICK}-Chris
Admin
Posts: 899
brainmark schrieb:

Hi.

Ich greife dieses Thema noch einmal auf, da ich auch dieses Problem habe und so langsam an mir selber zweifel.
Heute habe ich mir das aktuelle Xampp (7.2.3 / PHP 7.2.3) runtergeladen und installiert.
Fix die aktuellste DZCP-Version von dzcp.de runtergeladen und nach c:xampphtdocsDZCP kopiert.

Allerdings bekomme ich bei der Installation (http://127.0.0.1/DZCP/_installer/install.php?action=database&do=install) folgende Meldung:

 

Fatal error: Uncaught Error: Call to a member function query() on null in C:xampphtdocsDZCPincconfig.php:256 Stack trace: #0 C:xampphtdocsDZCP_installerconfmysql.php(15): db('DROP TABLE IF E...') #1 C:xampphtdocsDZCP_installerinstall.php(456): install_mysql('test', 'tester', '1234', 'test@test.d...') #2 {main} thrown in C:xampphtdocsDZCPincconfig.php on line 256

 

So langsam befürchte ich, das es an der aktuellen Xampp-Version bzw. php-Version liegt.



Wann kommt dieser Fehler? Also zu welchem Zeitpunkt der Installation?

Hast du Xampp als Admin gestartet? Welches Betriebssystem nutzt du?

 

Ich selber habe auch regelmäßig Probleme mit Xampp. Bei mir liegt es an der maximalen Scriptlaufzeit. Ich habe das Gefühl, xampp ist deutlich langsamer, als Apache, MySql Server, etc einzeln zu installieren.

Falls du also die Meldung bei der Installation bekommst, wäre meine Idee, erstmal die maximale Scriptlaufzeit raus zu nehmen....

 

Ändere dazu VOR DER INSTALLATION die Datei: /_installer/install.php.

In Zeile 455 steht @set_time_limit(60); . Entweder nimmst du das raus oder

du trägst da 300 oder mehr ein. Wenn du (bei 300) nach 5 Minuten kein

Ergebnis hast, weißt du, dass es nicht an der Geschwindigkeit von Xampp

in Verbindung mit deinem Rechner liegt, sondern es ein anderes Problem gibt.

 

 

lg. Chris

 



zuletzt editiert von -{ICK}-Chris am 19.03.2018 11:11 Uhr 



Es kmmot auf die Vrpunekacg an!

IP gespeichert
#7 am 19.03.2018 um 19:07 Uhr Diesen Beitrag zitieren
acecom
Moderator
Posts: 1943

Versuche das ganze mal mit Joomla zu Testen! Ich gehe aber davon aus das es das selbe ergebinss ist wie mit DZCP. 

Versuch nochmals DZCP zu installieren. Sobald der Fehler auftritt, schau bitte in den Ordner dzcp/inc/ ob dort eine File mysql.php erstellt wurde. Bitte Prüfe auch mit PhpMyAdmin ob eine Datenbank erstellt wurden ist. 

In welchen Schritt der Installation tritt der Fehler genau auf?

Prüfe bitte auch im Xampp Windows Fenster ob Apache und MySql gestartet sind und werf auch mal ein Blick in die Log.

https://www.apachefriends.org/faq_windows.html



zuletzt editiert von acecom am 19.03.2018 19:09 Uhr 



Google Ist Dein Freund !!!

IP gespeichert
#8 am 19.03.2018 um 21:12 Uhr Diesen Beitrag zitieren
brainmark
User
Posts: 18

Vielen Dank für eure Antworten.

 

@Chris: Ich habe Windows 10 (1709 Build 16299.309) und Xampp als Admin ausgeführt.

Bei mir ist der Apache und SQL recht fix. Zumindest hatte ich, was die Geschwindigkeit betrifft, noch keine Probleme.

Die Fehlermeldung taucht bei Schritt 5 der Installation auf. Wenn ich auf "deV!L`z Clanportal installieren!" klicke, kommt sofort die Fehlermeldung. Mausklick und da.

 

@acecom: DZCP hat eine mysql.php mit den von mir vorgegebenen Werten angelegt; die Datenbank ist jedoch komplett leer.

 

Im Apache Error-Log steht folgendes: [Mon Mar 19 21:00:40.241179 2018] [php7:error] [pid 11768:tid 1968] [client 127.0.0.1:58520] PHP Fatal error:  Uncaught Error: Call to a member function query() on null in C:\xampp\htdocs\dzcp\inc\config.php:256nStack trace:n#0 C:\xampp\htdocs\dzcp\_installer\conf\mysql.php(15): db('DROP TABLE IF E...')n#1 C:\xampp\htdocs\dzcp\_installer\install.php(456): install_mysql('test', 'tester', '123456', 'test@tester.d...')n#2 {main}n  thrown in C:\xampp\htdocs\dzcp\inc\config.php on line 256, referer: http://127.0.0.1/dzcp/_installer/install.php?action=database

 

Im MySQL Error-Log gibt es zu dem Zeitpunkt keinen Eintrag.

Ich werde jetzt mal Joomla probieren. Bin gespannt.

 
IP gespeichert
#9 am 19.03.2018 um 21:20 Uhr Diesen Beitrag zitieren
brainmark
User
Posts: 18

Nachtrag: Die Joomla 3.8.6 Installation lief ohne Probleme durch.

 
IP gespeichert
#10 am 20.03.2018 um 07:29 Uhr Diesen Beitrag zitieren
Hammermaps.de DEV
Coder
Posts: 369

Ich schaue nachher mal, du hast aktuell php 7.1 oder höher am laufen?

Wäre nicht schlecht, wenn du heute  abend on wärst.

 
IP gespeichert
#11 am 20.03.2018 um 09:41 Uhr Diesen Beitrag zitieren
brainmark
User
Posts: 18

Guten Morgen Hammermaps!

 

Ich habe die aktuellste Version von Xammp installiert.

Das ist die PHP Version 7.2.3, MariaDB 10.1.31 und phpMyAdmin 4.7.9 (beides laut Apachefriends).

 

Ich werde affig! hail.gif

Das Problem ist das leer gelassene SQL-Passwort!

Aus Faulheit setze ich normalerweise lokal keins.

Gerade habe ich noch mal eins gesetzt und nun läuft die Installation durch!

Bei der Joomla Installation hatte ich das Passwort auch leer.

Es wäre schön, wenn man das DZCP-Installationsscript dementsprechend anpassen könnte, damit solche faulen Typen wie ich nicht gleich einen Forenbeitrag schreiben, nur weil sie das SQL-Passwort leer lassen.

Ich danke euch allen für eure Hilfe und eure Zeit!

 

Vielen, vielen Dank!

 
IP gespeichert
Seite: « 1 2 »